Ioncube Loader installieren

Bei der Installation einiger PHP-Programme wird der IonCube Loader benötigt.
Das Modul IonCube Loader steht bei uns vorkompiliert zur Verfügung. Es wird im Kundenmenu unter Domainverwaltung über die Zend-Extension geladen.

Den PHP.INI-Editor öffnen und stellen auf Domainspezifische Einstellung um.
Tragen Sie unter Sonstige Einstellungen in Abhängigkeit der PHP Version in der Zeile "zend_extension" folgendes Verzeichnis ein.

 PHP-Version 4-STABLE:   
/usr/local/lib/php_modules/4-STABLE/ioncube_loader_lin_4.4.so   
PHP-Version 5-STABLE:    
/usr/local/lib/php_modules/5-STABLE/ioncube_loader_lin_5.2.so   
PHP-Version 5-53-STABLE:    
/usr/local/lib/php_modules/5-53STABLE/ioncube_loader_lin_5.3.so   
PHP-Version 5-53-LATEST:   
/usr/local/lib/php_modules/5-53LATEST/ioncube_loader_lin_5.3.so   
PHP-Version 5-54-STABLE:   
/usr/local/lib/php_modules/5-54STABLE/ioncube_loader_lin_5.4.so
PHP-Version 5-54-LATEST:   
/usr/local/lib/php_modules/5-54LATEST/ioncube_loader_lin_5.4.so
PHP-Version 5-54-LEGACY:   
/usr/local/lib/php_modules/5-54LEGACY/ioncube_loader_lin_5.4.so
PHP-Version 5-55-STABLE:   
/usr/local/lib/php_modules/5-55STABLE/ioncube_loader_lin_5.5.so
PHP-Version 5-56-STABLE:   
/usr/local/lib/php_modules/5-56STABLE/ioncube_loader_lin_5.6.so
PHP-Version 5-56-LATEST:   
/usr/local/lib/php_modules/5-56LATEST/ioncube_loader_lin_5.6.so

Für die PHP-Version 5-56-LATEST ist der Eintrag dann wie folgt:

zend_extension="/usr/local/lib/php_modules/5-56LATEST/ioncube_loader_lin_5.6.so"